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Purpose of the Document 

The purpose of this document is to explain the technical specifications and manual for using 
the Cat NB2 NB-IoT & GNSS USB modem. 

 

Document History 
 

Version Author Date Description 
A 5G HUB 08.12.2020 Initial Document 
B 5G HUB 02.28.2021 Add download Section 
C 5G HUB 05.17.2022 Add Arduino support Section 
D 5G HUB 09.30.2023 Add BG95-M2 
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1 Package contents: 
 

1.1 Cat NB2 NB-IoT USB Modem Package: 
• Cat NB2/Cat M USB modem with LTE & GNSS antenna connectors. 

1.2 Download 
 
Arduino software can be downloaded from the following website: 
5G-NB-IoT/KitSketches at master · 5ghub/5G-NB-IoT (github.com) 
 
To use the board with Arduino IDE and starts running Arduino projects and sketches, install the 
following software: 
 
Install Arduino IDE for Windows from the following web site 
https://www.arduino.cc/en/Main/Software 
 
Download and Install LTE&GNSS modem driver for Windows OS: 
https://github.com/5ghub/5G-NB-IoT/tree/master/Driver 
 
Download and Install QNavigator and QCOM tools for Quectel BG95 here: 
https://github.com/5ghub/5G-NB-IoT/tree/master/Tools 
 
Download and install Arduino library (5G-NB-IoT_Arduino.zip) here: 
https://github.com/5ghub/5G-NB-IoT 
 
All the following software can be installed from the GitHub location here: 
https://github.com/5ghub/5G-NB-IoT 
 
LTE cellular connectivity on Windows OS for BG95 
  

https://5ghub.us/
https://github.com/5ghub/5G-NB-IoT/tree/master/KitSketches
https://www.arduino.cc/en/Main/Software
https://github.com/5ghub/5G-NB-IoT/tree/master/Driver
https://github.com/5ghub/5G-NB-IoT/tree/master/Tools
https://github.com/5ghub/5G-NB-IoT
https://github.com/5ghub/5G-NB-IoT
https://5ghub.us/wp-content/uploads/2021/03/LTE-cellular-connectivity-on-Windows-OS-for-BG95.pdf
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2 General Description 
2.1 Overview 
The Cat NB2 USB modem is a cellular and GPS modem in an USB stick form factor. The USB modem has 
UFL connectors for LTE & GNSS antennas.  The board is a powerful board that features a microcontroller 
and wireless modem. The microcontroller is an Microchip SAMD21G18A MCU which features a 32-bit 
ARM Cortex® M0+ core. The wireless modem is BG95-M3 which is an embedded Cat NB2 wireless 
communication module. BG95 wireless modem provides a maximum data rate of 588 Kbps downlink and 
1119 Kbps uplink. It provides data connectivity on LTE-FDD/GSM/EGPRS networks. It also provides GNSS 
to meet customers’ specific application demands 

The USB modem provides rich sets of Internet protocols, industry-standard interfaces 
(USB/UART/I2C/Status Indicator) and abundant functionalities. The board offer a high integration level 
and enables integrators and developers to easily design their applications and take advantage of the board 
low power consumption, many functionalities, and USB drivers for Windows 7/8/8.1/10, Linux and 
Android. 

The USB modem is a rich hardware board that can be used for the 4G LTE wireless technology and enables 
a variety of smart applications for devices.  It enables large number of applications such as wireless POS, 
smart metering, tracking, smart transportation, smart buildings, smart city, and smart homes. 

The board is also compatible with Arduino and Arduino software (IDE). Arduino sketches and examples 
are provided with the kit and additional sketches can be developed and uploaded to the board. 

2.2 Key Features 
• Microchip ATSAMD21G18 MCU 
• Quectel BG95-M2 or BG95-M3 Cat NB2/Cat M NB-IoT module 
• UFL connectors for LTE & GNSS antenna 
• Supports LTE NB-IoT and Machine Type Communications (MTC) 
• Supports GSM/EDGE (only with BG95-M3) 
• Global Frequency Band B1/B2/B3/B4/B5/B8/B12/B13/B18/B19/B20/B25/B28/B66/B71/B85 

(B26/B27 for Cat.M1) for LTE and 850/900/1800/1900MHz for EGPRS 
• Supports the protocols TCP/UDP/PPP/ SSL/ TLS/ FTP(S)/ HTTP(S)/ NITZ/ PING/ MQTT 
• Supports SMS 
• Supports GNSS technology (GPS, GLONASS, BeiDou/Compass, Galileo, QZSS) 
• Compact board size of 65.1 mm x 32mm  
• Nano USIM card slot 
• Arduino IDE Compatible 
• Works with Windows, Linux, or Android 
• Ready for smart applications and development (smart home, smart city, smart transportation, 

smart metering, smart farming, smart waste management, asset tracking, location, navigation, 
mapping, and timing applications). Application such as Gas Detector, Soil PH Tester, Optical 
Sensor, Machinery Alarm System, Irrigation Controller, Elevator, Asset Tracking Electronics, 
Person/Pet Tracking, Water/Gas Metering, Smart Parking System, Fire Hydrant, Smoke Alarm, 
Trash Bin, Street Lighting 

• The board can be powered via the USB connector 

https://5ghub.us/
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• Each of the 14 general purpose I/O pins on the board can be used for digital input or 
digital output using pinMode(), digitalWrite(), and digitalRead() functions. Pins used 
for PWM can be using analogWrite() function. All pins operate at 3.3 volts. Each pin can 
source or sink a maximum of 10 mA and has an internal pull-up resistor (disconnected 
by default) of 20-60 K ohm. 

2.3 Overview Diagrams 
 

 

Figure 1. USB Modem Overview Diagram – Top View 

 

 

Figure 2. USB Modem Overview Diagram – Bottom View 

2.4 Physical Characteristics 
The width and length of the USB modem is 32 mm (width) by 65 mm (length).  The board have two 
screw holes in each corner that allows the board to be attached to a surface or case.  

 

https://5ghub.us/
https://www.arduino.cc/en/Reference/PinMode
https://www.arduino.cc/en/Reference/DigitalWrite
https://www.arduino.cc/en/Reference/DigitalRead
https://www.arduino.cc/en/Reference/AnalogWrite
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Figure 3. Physical Characteristics. 
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2.5 Peripherals – Key Components 
 

 

 
Figure 4. USB Modem Top Side – Key Components 

 

 

 

 

 

 

 

https://5ghub.us/


 

9 USB Modem Rev 1.1                            Copyright © 5GHUB.US 

 

Figure 5. USB Modem Bottom Side – Key Components  

https://5ghub.us/
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2.6 Hardware Specification 
Technical Specification 
Microcontroller (MCU) ATSAMD21G18, 32-Bit ARM Cortex M0+ 
Clock Speed 48 MHz 
Flash Memory 256 KB 
SRAM 32 KB 
NB-IoT Module Quectel BG95-M2 or BG95-M2 
Dimension 30 mm (width) by 65 mm (length) 
Weight 22 grams 
Power Supply  USB (5V) 
LED LED1, LED2, Status LED, Netlight LED 
Interfacing Logic Voltage Level 
(Operating Voltage) 3.3V 

Voltage output 5V, 3.3V 
RESET buttons Not Mounted 
User-defined Button Not Mounted 
USB Switch 1 switch to connect to MCU directly or BG95 directly 
General-purpose digital I/O 
Pins 14 (A0-A5, PA6, PA7, SS, MOSI, MISO, SCK, SDA, SCL) 

GPIO 2 connected to BG95 
ADC 2 connected to BG95 
USB 1 
I2C 1 
SPI 1 
UART 1 
ADC pins 6 (8/10/12-bit ADC channels) 
DAC pin 1 (10-bit DAC) 
External interrupts 14 (All general-purpose PINs) 
PWM pin 6 
DC Current per I/O Pin 10 mA 
JTAG Debug Cortex Debug Connector (Single Wire Debug) 
USIM Nano 
GNSS GPS, GLONASS, BeiDou/Compass, Galileo, QZSS 
Antenna 1 main antenna and 1 GNSS antenna 

Band 

LTE-FDD: 
B1/B2/B3/B4/B5/B8/B12/B13/B18/B19/B20/B25/B28/B66/B71/B85 
(B26/B27 for Cat.M1)  
GSM/EGPR: 
850/900/1800/1900MHz 

Certification FCC, IC, CE 

Mobile Operator Certification Verizon, AT&T, T-Mobile, Vodafone, Rogers, Telus, China telecom, 
China Mobile, China Unicom 

Notes: 

- UART can be programmed through any of general-purpose pins. 
- SPI can be programmed through any of general-purpose pins. 

https://5ghub.us/
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2.7 PIN Description 
 

PIN DIRECTION Description 
USB Connector I The USB modem is powered from the USB port (3.8V-5V) 

LED1 (USER) O LED which can be controlled from MCU (D25). When the pin is 
HIGH value, the LED is on, when the pin is LOW, it is off 

LED2 (USER) O LED which can be controlled from MCU (D26). When the pin is 
HIGH value, the LED is on, when the pin is LOW, it is off 

LED (NET) O Indicate the BG95 operation status 
LED (STAT) O Indicate the BG95 network activity status 
MCU RESET 
button I Not mounted 

BG95 RESET 
button I Not mounted 

User Button I Not mounted 
USB Switch I 1 switch to connect to MCU directly or BG95 directly 

IOREF O 

Provides the voltage reference with which the MCU operates. A 
device can read the IOREF pin voltage and select the appropriate 
power source or enable voltage translators on the outputs for 
working with the 5V or 3.3V 

3.3V O 
3.3V generated by the on-board regulator. Maximum current 
drawn is 3A. The regulator also provides power to the MCU and 
BG95 

5V O 5V generated from the board. The board is supplied with power 
from USB connector (typical 5V) 

GND  Ground 
A0 IO Six analog inputs which can provide up to 12 bits of resolution 

(i.e. 4096 different values). By default, each input measures 
from ground to 3.3 volts, though is it possible to change the 
upper end of their range using the AREF pin 
A0 can also be used as a DAC output and provides a 10 bit 
voltage output with analogWrite() function 
Analog pins can be used as GPIOs 

A1 IO 
A2 IO 
A3 IO 
A4 IO 

A5 IO 

SCL IO I2C. The SCL (clock line). Can be used as GPIO 
SDA IO I2C. The SDA (data line). Can be used as GPIO 

AREFA I Input reference voltage for the analog inputs used for either he 
ADC or the DAC 

SCK IO SPI Interface. Can be used as GPIO 
MISO IO SPI Interface. Can be used as GPIO 
MOSI IO SPI Interface. Can be used as GPIO 
SS IO SPI Interface. Can be used as GPIO 
PA7 IO GPIO. Can be used as GPIO 
PA6 IO GPIO. Can be used as GPIO 
Cortex Debug 
Connector IO Using Single Wire Debug to burn bootloader and debug the 

board 
ADC0 I Connected to BG95. General purpose analogue to digital converter 

https://5ghub.us/
https://www.arduino.cc/en/Reference/AnalogWrite
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ADC1 I Connected to BG95. General purpose analogue to digital converter 
GPIO26 IO Connected to BG95. General purpose IO 
GPIO64 IO Connected to BG95. General purpose IO 
USIM I  Used to insert a Nano USIM. Connected to BG95 

USB Boot I Connected to BG95. Force the BG95 to enter emergency download 
mode 

 

Precaution 

The USB modem runs at 3.3V. The maximum voltage that the I/O pins can tolerate i s 3.3V. 
Applying voltages higher than 3.3V to any I/O pin could damage the board  

 

2.8 BG95 chipset 
All functionality of the BG95shipset shall be implemented excluding the following features. That is, the 
following features are not supported: 

- Audio, Earphone, and Codes are not supported. 
- PCM and I2C are not supported 
- PSM_IND and AP_READY are not supported 

 

2.9 Interface between SAM21D and BG95 
The Microcontroller communicates with the BG95 through UART interfaces: 

- UART1: (PA12/PA13/PA14/PA15). Used for data transmission and AT command communication 
115200bps by default. The default frame format is 8N1 (8 data bits, no parity, 1 stop bit) Support 
RTS and CTS hardware flow control. 

- RI/DCD: (PB10/PB11). 
 

  

https://5ghub.us/
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3 Using the Board with Arduino IDE 
3.1 Installing the Software 
To use the board with Arduino IDE and starts running Arduino projects and sketches, install the 
following software: 

3.2 Setting Up the Board 
Gently move the switch S1 upward to put the board in Arduino mode as in the picture below. 

 

 

3.3 Setting Up Arduino IDE 
1- Insert the USB modem into the USB port of a computer. Launch Windows device manager and 

you shall see the Arduino board as below. 

 

https://5ghub.us/


 

14 USB Modem Rev 1.1                            Copyright © 5GHUB.US 

 
 

2- Launch Arduino IDE and choose File->Preferences. In the Additional Boards Manager URLs, 
insert the following URL: 

https://raw.githubusercontent.com/5ghub/5G-NB-IoT/master/package_5G-NB-IoT_index.json 
 

 
 

3- In Arduino IDE, choose Tools->Board->Boards Manager, select and install “5G-NB-IoT SAMD 
Boards”. 

https://5ghub.us/
https://raw.githubusercontent.com/5ghub/5G-NB-IoT/master/package_5G-NB-IoT_index.json
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4- Choose “5G NB-IoT (Native USB Port)” 
  

 
 

5- In the Arduino IDE, Choose Port and select the serial port where the board appears. 

https://5ghub.us/
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6- In the Arduino IDE, Choose Sketch->Include Library->Add .Zip Library and select the file  
5G-NB-IoT_Arduino.zip  
 
You are now ready to start running Arduino sketches and projects. 
 

 

https://5ghub.us/
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3.4 Running Arduino Sketch 
1- Using Arduino IDE, open any Arduino sketch such as TurnOnAllPins.ino, choose Sketch->Upload 

and it will run on the USB modem. 
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